Commands Only Working for Mods

Hello, first time here. If this topic is in wrong place, feel free to move it. Anyway…

So, trying out Nightbot in Chat today and my commands only work for those that are already MODS. Non-Mods, commands don’t work. I have my commands set to Everyone and yet…Mods are the only ones able to use commands.

Where am I going wrong? Where do I go to fix and troubleshoot?

Thanks in advance.

Hey @Chiprocks!

Are the commands that not everyone can use custom commands?

Not sure what you asking. I have all my Custom Commands set to Everyone.

Would you mind giving me a link to your commands list? I’ll have a quick look.

I tried putting in a link and got a message from this forum saying “New users can’t post links”

Ah yes, I just need what comes after

So how do I go about getting you the info you need Emily?

By giving me your YouTube ID (the end of your channel URL).
I haven’t found you using Chiprocks, so I believe you’re on YouTube?

Other solution is to take screenshots, but you might not be able to upload files either.

Correct. I’m using Nightbot for YouTube Chat.

Okay, it should work given the screenshot.
I’m no specialist with Nightbot on YouTube, however, what I know is that it answers in the Live Chat, and not the Top Chat, so make sure people are looking there when they call the commands.

Yeah, the commands work in YouTube Live Chat if they are Mods. Anyone else, commands don’t work even though all of them are set to Everyone.

Hmm, I doubt this would be the origin of the issue since it usually doesn’t impact custom commands, but make sure !commands is set to everyone and enabled as well.
Just guessing around to try to find where the issue could be at this point…

Also, I felt like it wasn’t necessary to give you this link since Nightbot was responding in your chat, but have a look here if you haven’t already, we never know: Nightbot Troubleshooting

Yeah, !commands is working in Chat and yes, already read through troubleshooting. Even my Chat Logs show that Nightbot is working…for the most part that is.

That is very odd, I’m afraid I don’t have the solution, sorry…
Last thing you could try is to make Nightbot part the channel, logout, log back in, and make Nightbot join the channel again, you’ll only be able to know if it worked next stream.

There is a cooldown on commands, which may lead you to believe mods can use them but users cannot. You can reduce the cooldown for commands in the command settings.

1 Like

Well, what I did when the problems presented itself, I would turn non-mods into Mods and suddenly they were able to use the commands and have them working in chat. Then afterwards, I took away their Mod status to test it out again and as before, commands no longer working for them.

Yeah, Night might be right, it can be because of the cooldowns, check your cooldowns.
I didn’t think of it because usually people don’t spam commands, but if it were the case, then only mods+ can bypass the cooldowns, and other chatters wouldn’t be able to use the commands until the cooldown is over.

Don’t think that theory applies in this case. I had subs coming in and I specifically told them to type in such and such command to test them out. So the cooldown doesn’t factor into it given that they hadn’t typed in any commands until I told them which command to type.

Cooldowns are not specific to users, they’re command based, meaning that if, for example, your !instagram command has a cooldown of 5min and someone calls it, then no one (except mods+) will be able to use the !instagram command for another 5min. Sorry if it was unclear.

Ah. Ok. Well, I guess I can go back and set any of the cooldowns to the bare minimum (default) and see if that fixes the problem.

1 Like