Song request broken for this song

I’ve been a Moderator for a channel and had a request using !umad with the song request of

This command was using a custom command I made that still works (not sharing it), but also the I have also use the new alias to make the song request for it with !song request (also !songrequest) xzpndHtdl9A, but it will constantly auto lower casing the request line causing it to not link anymore.

We do not lowercase anything when people request songs, so you are mistaken. Additionally, you should just use built-in shortcuts, like !sr instead of making your own.

Like I said above the custom command was used, I have started to edit those commands to use Nightbot Dashboard Alias section of the custom commands to use the “!sr” or “!songrequest” command directly. This sadly doesn’t work correctly due to once hitting Submit it will break the video URL of “zpndHtdl9A” turn it into “xzpndhtdl9a” which will not link to any video. This is the reason I have tried using a custom command which would work the same. What I have found is the anyone using !songrequest normally will be able to “!songrequest xzpndHtdl9A” and get the correct video above. But only through the custom commands via Alias or the custom command I use to do the same it will always request a different song the the post above mostly it’s: All I can say to this it has to be how Nightbot either calls its store custom commands, since a user can get the correct video while using Nightbot for a command song request does not.

Well unfortunately without you at least telling us the channel name experiencing problems, or even more information about the exact settings you’ve set the command to, we’re unable to provide you assistance…

I just had help from someone to test the song request on the channel and it does seem to have an issue so the channels is The command is !umad and I’ve changed the command to Mod only to keep it from being used by normal people at the moment, if it needs changed so you can see I will.

I’ve had it set with the normal Alias setting to with a message of Umad.

“!songrequest xzpndHtdl9A”

This turns into

“!songrequest xzpndhtdl9a”

The custom commands I’ve used just do exactly the same thing the Alias section already does, but I was hoping to get past the issue of a random song by going through a different method. Sorry if I’m making you annoyed, or if this is annoying.

Is this kind of what you’re trying to do?

This is due to user error. You should only enter the command in the alias box, not the parameters too. Any parameters to give to the command must go in the message field…

That fixed my issue thank you.

It seems that the change from when the commands were made, updated and now a lot of things changed that caused all my problems sorry for any inconveniences I caused.