!wins counter that adds wins (help)

Hello, I came here and made a topic to ask for help with RokettoJanpu’s !wins command.

Everything works on the command itself but it gives me a ‘Unexpected end of input’ response when the !wins command is typed. Would anyone know a fix for this issue? Or any way to reach out to RokettoJanpu? Thanks!

Hello, it would help if you could link @RokettoJanpu’s !wins command as from what I can tell there are multiple and it’s not clear as to which one you used.
Though if you would like to reach out to him just click the box labeled “Message” on his profile page.

Ah yes, here is the link to the commands I used. I’ll also send him a message as well, thanks! :slight_smile:

Still looking for a fix :frowning:

Did you change anything when you added the command besides the command names and public and private tokens? As I can’t check them myself I recommend to you counting the number of ` and () making sure it’s even as that’s the most likely cause of the end of input error.

Same error, copied the code as posted by @RokettoJanpu and replaced it with my Token.

Nightbot: Unexpected end of input.

() 11x
{} 2x
1 11x

I’m assuming the 1 is supposed to be a ` and if that is the case you should only ever have an even number of them and since you have 11 you are most likely missing one. I would suggest recopying the command and making sure when u enter your token that you don’t delete any of them as this is what is the most likely cause of the issue.

I fixed it in the end :slight_smile:

However, when doing !setwin and then doing !wins it says 0 wins and 0 kills guess it’s all a little broken/out dated.

@PandaClub How did you fix this as I am coming across the same thing? I am only receiving this error when attempting to use the !wins command. The other commands work fine. Any help would be appreciated

Unfortunately, although i fixed the !wins from working it will always show 0 wins and 0 kills. It won’t seem to track so i just gave up lol.

Hey @omunch, @PandaClub and @irish_phenom!

I’m sorry, but the commands work perfectly, I gave them a try, so the issue is on your ends, make sure you copied the code properly and replaced the TOKENS with the proper ones without deleting important part of the code.


Interesting. Seems we’re using different versions as i don’t have addkill command. Only addwin and _!addwin.

Are you using the one [22309]? I’m using the other version [#24088] , i’ll try this one.

Seems i can’t post links to other threads which is silly, external links expected but even nightdev threads? lol

Update 1: It’s working now. Manually added it via Nightbot dashboard not via chat command cutting the string off.

Update 2: I switched to the #21791 version which support total wins as well.

I was talking about the one that was linked in this thread, so that would be 22309.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.