NightDev Community Forums

Trying to add a subcount that keeps adding 1 to the subcount so it never ends

$(channel) is $(twitch $(channel) “{{subscriberCount}}”) / $(eval $(twitch $(channel) “{{subscriberCount}}”) + 1) subs away from reaching the goal!

I put this into nightbot but it keeps giving me this when I try and put it into the chat

********* is Not authorized to access channel’s subscriptions. Has the channel owner logged into the Nightbot control panel? / Unexpected identifier subs away from reaching the goal!

It works on a different channel and everything else but not the channel i’m trying to add it to.

What platform is this?

This is on twitch that I’m trying to put it on

Hey @kotamaolsaris!

If I had to guess — because “it doesn’t work” doesn’t mean anything to us, you need to give us more details — the issue has to be the quotation marks: “”, because if I write your code with the proper ones: "", it works just fine:

Also, you can improve your code this way:

$(eval s=parseInt(`$(twitch $(channel) "{{subscriberCount}}")`); `$(channel) is ${s}/${s+1} subs away from reaching the goal!`)

I tried this and when I put it into commands it still gives me “Has the channel owner logged into the Nightbot control panel? / Unexpected identifier”

Is there a setting somewhere that I need to change this? Or could it be because of a different bot that I could be using that is stopping it from working. As you said it worked for your channel but it isn’t working on the one channel I’m trying to put it on.

Then have you tried doing what the error message says?
The streamer needs to go to nightbot.tv, log out if they’re already logged in, and then log back in.

I’ve tried to do everything that I know and nothing has worked so far. Even someone else I know was trying to help me so he did the commands on his own and they are working. The stream that its not working for doesn’t make sense because they never changed any settings to it.

Yes okay, but did you try logging out and back in?

I have tried to log in and out and it still wont work.

Try the command I wrote, copy/paste it to replace your current one.
If it still doesn’t work, log out again, wait a couple minutes, and log back in, it seems to have brought results in the past even though it shouldn’t require to wait some time.