Playlist/Auto DJ issues


#1

Currently nightbot is not importing my entire playlist, only a portion of it, and it’s also refusing to play the playlist when running Auto DJ. None of the songs are private or deleted and it’s a public playlist. I’m also having an issue with the permit levels associated with it. I can’t allow regulars and up, ie subs, to be able to request songs, it’s only either or and it’s rather frustrating that you can’t allow multiple levels of permissions.


#2

Currently nightbot is not importing my entire playlist, only a portion of it

Are you sure the tracks being imported within your playlist are eligible to be imported? We ignore ineligible tracks when importing an entire playlist, but you can manually import individual entries to see the individual errors.

it’s also refusing to play the playlist when running Auto DJ

You would need to be more specific about this, as I’m not sure what you mean. AutoDJ is intended to be used for song requests, not playing your own playlist. We only backfill from your playlist on page load if your song request queue is empty.

I’m also having an issue with the permit levels associated with it. I can’t allow regulars and up, ie subs, to be able to request songs, it’s only either or and it’s rather frustrating that you can’t allow multiple levels of permissions.

Permissions are a hierarchy. Everyone < Subscribers < Regulars < Moderators < Owner. If you want Subscribers and up to have song requests, you should set the permission to Subscribers.


#3

None of the tracks are ineligible, though. They’re all publicly available and I don’t understand why they wouldn’t be loaded in.

Yes, but it’s not loading in songs in when the queue is empty, it’s giving an error message. It’s not constant, but it’s annoying to have to tab out of the game to fix it.

So, regulars are higher on the hierarchy than subs? I didn’t know that, I thought it was reversed.


#4

None of the tracks are ineligible, though. They’re all publicly available and I don’t understand why they wouldn’t be loaded in.

Are you 100% sure? I would suggest actually trying the individual tracks as requested before making a blanket statement.

Yes, but it’s not loading in songs in when the queue is empty, it’s giving an error message. It’s not constant, but it’s annoying to have to tab out of the game to fix it.

What is the error message? What does the page look like when it’s in this state? Do you have steps to reproduce this issue?


#5

That will take a while because it’s almost 1000 tracks to have to go through and test to add in nightbot, but any time I’ve scrolled through the list on youtube there’s been no missing videos or any that were taken down. Also, sometimes when I try to load in the list it will say that the entire playlist doesn’t exist or is ineligible, but that’s usually after I try to load the playlist more than once because I’ve cleared it out and it’s only bringing up a tiny fraction of the songs on the list. Usually what happens there is that I’ll clear out the playlist, try to load it and only get sub 50 songs, then try to load it again and get over 500, and try to load it a 3rd time and it tops out at under 900.

The error message is that there are no tracks found and it usually comes up after I’ve gotten an error message trying to load the playlist. Usually I have to swap between autoDJ and another section on nightbot and the playlist comes back, but sometimes I’ll have no issues through a dozen songs and then it pops.


#6

Are you still experiencing this issue? Providing a playlist link or a way to reproduce this issue can help narrow down the reason this might be happening.