!permit in Discord

Well hello there!

I’m encountering the following problem:
We have Nightbot active in a Discord server, and it is protecting the chat like we know and love from Nightbot! However, !permit doesn’t seem to work, I imagine this is a ‘naming’ problem? Since it gives the response that the user can post the link, but still deletes the link when posted. Does Nightbot simply not read the correct user? Any know fix for this?

Thanks in advance!

It does sound like the name typed in !permit are not being tied to the discord user. Are you using !permit @username? Or are you just doing !permit username because it will make a difference, i believe you will need to do the @username so nightbot knows to tie the name with a specific user id

I tried (and just double checked) both ways, sadly no difference. Can anyone confirm it works in their own Discord? Cause then i’m sure it’s something in our side of the settings, and not on Nightbots side :smiley:

Ty for the quick response btw!

Oh yea, i am getting this issue as well. I could have sworn that worked in an earlier version, thank you for reporting.

Aah oke!

Is there somewhere I report it?
Ty for checking!

This should be fixed now.

Can confirm that it has been fixed after testing on my server.

Yep, it works now. Awesome work and thanks for the fast fix!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.