NightDev Community Forums

Nightbot !sr not working

I have modded nightbot but when i do !sr !song request !songrequest etc then the song info nothing happens. it doesn’t say cant find the song or searching for it or anything. iv tried the commands from the docs they didn’t work either. dam i just using it wrong or do i need to set up a custom command? I really need help with it as its stopping me from streaming as good as i could (which isn’t great I am new to streaming but not the point…) I just wanna get it fixed asap if I’m being a idiot Lmk what I’m doing wrong plz

Double check that default !songs command is enabled here. Also check that you have no custom command that is overwriting the !songs command. Commands such as !sr or !songs can effect the default ones.

I have no custom commands set up and it’s definitely enabled and it can be used by everyone and the song request amount limits 2 per person unless your a moderator. As far as I can see everything is set up to work that’s why I’m really confused why it’s not working. I also tried removing it from my channel then reading the bot. Is there something else I need to enable/disable? Could anything else be affecting it. When I add songs manually on the dashboard I can hear the music on my stream but using the command its not working. Is it possible to set up a custom command to fix the problem I’m having?

Hey @chilly_on_minecraft!

Please see here and let us know if that helped: