Nightbot doesn't seem to respond to most of my commands

I recently installed Nightbot because I needed a bot that can do everything without having to pay, like Moobot. However when I installed him and modded him, nb appears in my chat and responds to !songrequest but does not do anything else, nb does not activate timers and does not show messages upon command. I am running the latest version of online Nightbot. I don’t know what I did wrong, can someone please help?
Thanks, Gunner

Please check that everything you want is enabled in the Nightbot Control Panel. Nightbot should respond pretty quick if your using Twitch. If your using YouTube Gaming instead then Nightbot will only work when live and has a reasonable delay due to the chat system. The more active the chat is the faster that Nightbot replies, hope this helps you out.

I have the exact same problem, wasnt able to make it run so far.
Rejoining doesnt do anything, Nightbot is not banned but is a moderator and the button in the dashboard says “part channel” all the time - it still ignores all commands.
Timer worked once i think.

Both of you have custom commands configured with nonexistent aliases. I’ve added an error handler so when people now use a nonexistent alias you will get an error in chat.

Thanks for the reply! What do you exactly mean with nonexistent aliases?
I thought that the alias is supposed to just be where i enter other commands to enter.
Maybe the explaination should be made more clear, like a dropdown of other commands instead of free typing.

As is stated below that field on the website,

If this command is supposed to call another command, specify the other command here.

This means that if you make a custom command called !two and you want it to call !one, you would specify !one in the alias field of !two.

I guess a dropdown would make more sense regarding that.
Anyways, while the nightbot specific commands work now (!title & !commands), the custom ones dont work (i removed all alias entries). I tried !help.

It’s complicated since we also need to pull default commands as well. It’s something we’ll eventually add, but the interface for custom commands likely change a lot in the future to be more user-friendly.

This was a bug caused by a bad code push. It has been fixed at this time.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.