!multi and !multiset command

[i]Multi-stream commands to show the link get annoying if you keep entering in the username afterwards. Here are two commands to make your lives a little easier. One command for users to get the link and a command for moderators to change the user.

Command for Users:

!commands add !multi Current Link: http://multitwitch.tv/

Command for Moderators:

!commands add !multiset -ul=moderator -a=!commands edit !multi * *Current Multi-Stream Link: http://multitwitch.tv/$(channel)/$(query)

When you need to change the multi-stream link just follow the example:

!multiset Kappa

and the !multi command will update to respond with:

Current Multi-Stream Link: http://multitwitch.tv/aaron128l/Kappa

This supports all types of different multi-stream services. Just be sure to edit the !multiset command and put the $(query) in the right place of the link. Enjoy.[/i]

This doesn’t seem to work using chat window input, anymore. What would be the multiset command if I were entering the command via nightbot dashboard? Help is greatly appreciated.

Hiya, what issue are you having? The provided commands should still work fine from the chat.

xgerhard!! How are you, dude? It’s been ages since I’ve seen you in stream! At any rate, basically, if I delete the !multi and !multiset commands from NB dashboard page, then enter into chat as above, it doesn’t seem to work.
So, I manually created the !multi command via NB dashboard, and then tried to manually create the !multiset in NB dashboard, but i cant seem to get the context in the message portion to be right…

!commands add !multiset -ul=moderator -a=!commands edit !multi
Current Multi-Stream Link: whatever/$(channel)/$(query)
If I manually create a command !multiset , then what would be proper in the Message box? I’ve tried from !commands edit… onward to the end and that still doesn’t seem to work. It created the link if I type !multiset xgerhard, then it returns that it created url but if you then type !multi, it doesn’t get updated from the !multiset command.
(this forum wouldn’t let me reply with a multitwitch URL, but you get the picture…)
Thanks for looking! Hope to talk soon!

Ah hey! Didn’t check/see your name last time, hope all is well, I’m doing fine, thanks!

Can you describe what isn’t working, what kind of response are you getting when you use the !multiset?
It should look something like this:

Example usage:



Looks like you’re missing the !commands command in the alias field at the bottom for the multiset command.

nothing returned from nightbot when I tested !multiset geriatricginger I’m configuring it for another streamer’s nightbot.


We’re getting closer… have you checked that the !commands command is enabled at: https://nightbot.tv/commands/default (and check in options that the userlevel isn’t set to owner).

That would also explain why adding the commands through the chat didn’t work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.