returned an error. Try again later

I’m trying to get Nightbot to show my current song in Twitch chat. My Spotify is connected to my profile, and I’ve added the command !song like this: !commands add !song $(lastfm Frelzor), as per instructions from the Nightbot Docs (Lastfm variables).

It looks like this in my commands section:

Yet, whenever someone try to type in the command !song, the Nightbot only gives an error message:


The song scrobbles correctly on my, so I’m not sure what I’m doing wrong?

Hey @frelzor!

Did you try again? It says to “try again later”, it’s possible API was having an issue, and it’s now resolved. Also, are you using your username in the command (and not your Twitch username) like the documentation asks you to?

Hi @Emily,

Thanks for your reply! Yeah, I have tried again later - it’s still a problem.
And yes - I am using my username (it’s the same as Twitch).

Any ideas about what might be the problem?

Hey @frelzor!

Sorry about the delay, I was away for a few days.

I think I have an idea, in your privacy settings, make sure your recent listens aren’t private, so make sure this box isn’t ticked.

I visited your profile, and I couldn’t see your recent plays, so I think it’s the issue here.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.