Export/backup function can't handle umlauts

Hey there,

in case you entered keywords that should highlighted in chat containing umlauts or other special characters, then backup/export your BTTV settings, the umlauts and special characters are saved as “�”.

In my case I want to highlight the German word “fußball” (football). The exported json (.backup) file has the value “fu�ball”. This is the case with German umlauts like ä, ü, ö as well.

Hey @Savory_Savory!

There’s already an opened issue on the repository, so it should be fixed at some point, but we’ll greatly appreciate if you can add more details.


It seem thing with nickname case. I try to open my backupfile by notepad. It show some error code like “bttv_nicknames”:{“imapt”:“I-a-8H”,“maris”:"!2#4*",“teanskylighs”: I-a5",“cool_s”:“A!eL”}. How to convert them to the German word?

You can’t really convert it back, but you should be able to edit it and save the file properly. I think the issue is due to the encoding settings used whilst saving, not sure if it’s using UTF-8, but I reckon that’d be the best one, and the fact that it converts characters that are outside the US keyboard makes me think it’s probably using ANSI.


This is fixed in version 7.3.6. Indeed, the saved file’s encoding is incorrect. If you resave it with utf-8 encoding it will work properly.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.