Discord integration

Hi! I can’t seem to add, edit, or delete commands in the discord server I’m an admin for. When I try to manually add the command (ex: !addcom !test testing…) nothing happens and if I add the command a different way (ex: /commands add name: test response: testing) it gives me the message “That command does not exist or you do not have the permission to use it.” I have disconnected and reconnected my Twitch & Discord accounts, I have parted the bot from the server multiple times, I have given the bot the highest roles in the server to have access to all the channels, I have made sure the “Role Syncing” box is checked under Integrations settings and I’ve clicked update multiple times and made sure to type in a chat so that the bot could integrate the roles. I can only use the commands that I make through the dashboard, but when it comes to editing, adding and deleting I cannot do. Is there any way to fix this? Thankyou!

does it recognize that admin role as a moderator in the dashboard?

I’m not sure how I would check that, I’m sorry! Whenever I pull up the dashboard and go to integrations and click on settings, the Moderator Role is set to the role we have for Twitch Mods in the server if that’s what you mean. I’ve also tried to set the Admin role in place of the Moderator Role and it wouldn’t work

have u tried giving yourself the twitch mod role in datcord?

Yes, I have the Twitch Mod Role and Admin Role myself

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.