NightDev Community Forums

Commands changing its own userlevel

#1

So i’ve created a command as a moderator in someone elses channel and initially made the userlevel moderator. It worked for about 1 minute but then had changed itself to be Owner only. I then asked the streamer to delete it so i could make it for everyone (using the -ul tag just in case), that too worked for about a minute before changing to Owner again. I have absolutely no clue how or why the userlevel is changing on its own. The exact same command with the exact same tags works perfectly fine without issue on my own channel, just not the channel i moderate.
This is the exact command i was executing
!addcom !icebreaker -ul=everyone -cd=60 $(eval a=$(urlfetch json https://pastebin.com/raw/UYvrDRyf);a[Math.floor(Math.random()*a.length)])

The purpose of the command was to get nightbot to read from a pastebin to post a random question in the chatroom. Again, this works flawlessly in my channel, adding the command both via the chat and via nightbot dashboard, but keeps changing the Userlevel to Owner when added to someone elses channel via chat as a moderator.

Anyone got any idea how this is even happening? And better yet, how to stop this happening?

#2

It doesn’t change to owner on its own. It’s probably the broadcaster or another moderator doing that.

#3

That’s the thing, they weren’t. The broadcaster was not changing it, (don’t even think he knows how), there’s only one moderator who has access to the broadcaster’s NightBot dashboard, and they were not changing it. (don’t even think they were in the channel at the time), and it was not being done in the chat by any other regular moderator.

The command could be created and left and would remain at the selected userlevel, but when someone used the command, it would change userlevel seconds later.

This is why it was confusing me.

Nevertheless, we are using an alternative to this now.

closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.