Can't echo a Twitch emote in Discord

I’m trying to make the command failsS display the Twitch emote failsS in Discord. To get it to trigger, I’ve run:

!commands add <:failsS:448768409992167444> <:failsS:448768409992167444>

However, no matter what I try, it’s printing:


Nightbot has a subscription to the Twitch channel (failstream). I’ve tried creating the command in Twitch chat to avoid any escaping issues. I’ve tried:

!commands add <:failsS:448768409992167444> failsS
!commands add <:failsS:448768409992167444> :failsS:
!commands add <:failsS:448768409992167444> \<:failsS:448768409992167444>

Nothing seems to work.

This syntax does work for Discord server emotes, just not for Twitch ones. I’m at a loss.

Hey @dx_over_dt!

I believe it’s due to the fact that Discord used to consider Nightbot somewhat like an user because it’s an old bot, so it could have the subscriber role, but that recently changed because Nightbot had too many subscriber roles, and it was becoming too heavy on Discord to handle, so now it’s considered like other bots, and therefore can’t have a subscriber role, which means it doesn’t have access to Twitch emotes anymore, sorry.

Thanks for the explanation!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.