NightDev Community Forums

!alias usage command

Hi . . . How can i delete !alias usage ?

Example: !addcom !uptime 7 minutes
!addcom !time -a=!uptime

Then i delete the !uptime command and the bot write:

The alias you set this command to be of, !uptime , does not exist.

I tried !delcom time command … then !addcom the command again but it doesn’t work

Hey @XIYato1!

An alias can be used to have identic commands with different names, a bit like shortcuts, or to write longer JS code, other than that, it’s useless to use aliases in custom commands.

When you set !uptime to be the alias of !time, it means that when you’ll call !time, the output will be the one of !uptime, then if you delete !uptime, !time can no longer function properly.
To remove !uptime from the alias of !time, either you can delete !time and add it again without the alias part, or you can go in the dashboard to remove it from the command by editing it, there is no other way, editing the !time command to remove the !uptime alias through the chat won’t work.
When you delete a command, make sure to include the exclamation mark (!) if it has one.

Wow i really tried to Delete the command and add it again but it doesn’t work
Now it’s working . . . Sorry for wasting your time and ty

1 Like