StreamTip API DELETE and GET request always gives me 404

Anytime I attempt to access a specific tip through the api with /tips/tid, whether it be with the DELETE or GET, I always get the response {“status”:404,“message”:“That transaction doesn’t exist.”}. I can pull the list of all tips, can manually add a tip, but accessing it fails each time with that same error. Is there an issue with accessing a manual tip through the API directly?

You need to use the transaction’s transactionId, not the _id. I apologize if the documentation isn’t clear enough on addressing this. We will probably refactor the API (as v2) in the future to provide more information for transactions, and at that time we will most likely be using the _id instead.

Thing is though, I tried _id and the transactionId, neither worked and each give me doesn’t exist. Just to make sure I’m not messing anything up (which honestly I might be), the way I do the put is: (authorization in the header){$tid}

which I found strange because that tid I put isn’t set anywhere. It puts it in correctly though since it shows up in the interface but with a different transactionId. But oh well.

After playing around a bit, I did get the GET to work. Tried it from my browser like this:<tid>&client_id=<client_id>&access_token=<access_token>

but that’s an entirely different setup from the PUT. If I try that with the PUT it gives me a 500 Internal Server Error. If I try the format I used in the PUT with the GET request, I get that 404 Not Found. Now, when I try /tips/tid?tid= with the DELETE request, it gives me 400 Bad Request, if I put /tips/tid= it gives me the 404 Not Found.

I just really don’t know how the DELETE request is taken since both ways I tried (format of PUT and format of GET) both get rejected with even different errors.

I’m not sure why you are specifying the transactionId in that manner.

For example, if your transactionId is 29u8y3grfjewe9348rtugh, then the endpoint would be

I swear I tried that and it failed. Did it again and it worked. Thanks for your help! Solved everything.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.