Spotify ignoring nightbots playlist


#1

I recently put the nightbot app and spotify back on my computer. I had this problem where when I turned on autodj the song would play but when it finished instead of getting the next song from the que spotify would play a different song and autodj would turn off. After checking for updates and carefully making sure I went through the correct startup sequence the problem persisted. I finally hunted around online to see if others had had similar problems and could not find anyone having the same issue, but one guy did mention an advanced setting for spotify entitled “Allow spotify to be opened from the web.” I went into the advanced settings to discover that this was not my issue. But I read through all the advanced settings. and found “autoplay similar songs when your music ends.” I toggled this off and it resolved the issue.
I then turned it back on and saw that when a track from autodj would finish the next song would begin to play and then get skipped automatically (I know presume by spotify and not nightbot).
Turning it back off restored functionality without having to close nightbot or spotify.

Hope this helps other people out,
-GGH


#2

This has already been reported and addressed in this post:


#3

Same problem with me on mobile.


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.