!song not working

I have Song request enabled. every time i out !songs play it say something like songs request has been sent a play command ( if opened)… Its open and enabled but no music plays

I do not understand exactly what you are trying so its very tough to suggest something that can fix it.

Are you using nightbot through your browser or through the app?

Make sure that the AutoDJ page is open while you are trying to use it. It seems that the requests themselves are being done correctly so thats the only issue i can think of and it does mean that its properly enabled, so the only limitation would be on the playback.