SOLVED: Custom Command response shows text only after URL for specific channel and specific URL

SOLVED: This is an issue with Twitch’s AutoMod… even if the URL is added to the allowable terms.

EDIT (for simplification)
3-16 Edit (found another channel this happens to)

  • We have a custom command on VooDooUsh or OwnDogGames channel called !a. It contains text, a url, and more text.
  • Whenever we use it, the text BEFORE the url will not be shown. Only the url and the text AFTER the url will be shown.
  • This only happens if the URL is the Twitch-TV url for Stonegrasp and ONLY in the VooDooUsh channel.
  • The command works as expected if the URL is NOT the Stonegrasp Twitch URL.
  • The command also works for the Stonegrasp Twitch URL on all other channels. The issue happens with the VooDooUsh and OwnDogGames twitch channels.
  • We do have appropriate permissions.
  • We do not have the Stonegrasp Twitch URL in a blacklist anywhere.
  • See screenshot / examples in my replies.
  • Yes, we’ve tried creating completely new commands names and different text. As soon as the twitch url for Stonegrasp is used we run into this problem.
  • Yes, we’ve had nightbot part and rejoin the channel.

I believe that Nightbot may have a corrupted entry or something else is going on behind the scenes when it comes to the Stonegrasp URL for the VooDooUsh or OwnDogGames channels.

---- Original Message ----
For some reason our custom command, which has both text and a URL, is only showing the URL and text AFTER the URL. Also posted a message on twitter: twitter-DOT-com / Stonegrasp / status / 1239337468794753024

For example:
command: !stone
response: Soorey no shout-out for Stone twitch-url-for-stonegrasp-here and here is some more text.

When you do the command in twitch it will only respond with:
“twitch-url-for-stonegrasp-here and here is some more text.”

I’ve tested this with other user’s urls and it works fine with both text and the url… it seems like it’s ONLY the twitch url for stonegrasp?

The url hasn’t been added to any blacklist or anything on my side from what I can see.

We’ve even tried using different command names… same issue… only shows the URL and not the full text + url.

Can anyone help?

I wasn’t able to reproduce this error.

Try your command again. Perhaps whatever the issue was at the time has resolved itself.

This issue is exclusive to a particular channel. The command works completely fine for everyone’s channel except for a channel I manage.

2020-03-16 7-22-16 AM

I’ve even gone into the dashboard and managed the channel’s commands instead of doing it through the chat. When I do it this way all text BEFORE the url will not show up, only the url and then any text after.

Since I’m a new user I can only post one image per message.
Here’s where I manually add the command since using !addcom did not work (above). It did not work ONLY if I used the stonegrasp URL. Any other URL is completely fine.

and then when I execute the command in twitch I get this:

2020-03-16 7-27-04 AM

As you can see it’s cutting off all text from before the URL.

Again, this is ONLY happening for one particular channel that I manage: VooDooUsh. Not sure why this would happen. The URL is not on any blacklists or anything like that and I do have permission to create and execute commands.

Testing in my own personal channel, the command works as expected. This is an isolated issue for the VooDooUsh channel.


So… this is not a new issue… it’s been here for months. I’m really hoping someone that’s a dev or a support person can have a look at the issue as it seems unique to VooDooUsh’s channel and my twitch url.

So this issue is no longer isolated to VooDooUsh’s channel.

It is also happening with another streamer: OwnDogGames. If he gets Nightbot to do a shout-out, the text before the URL disappears and only the URL and anything after the text is shown.

Can anyone help with this? Not issue would happen ONLY for my twitch URL for the VooDooUsh channel and the OwnDogGames channel.

This issue is still happening.

Text before the URL in the command will not show up. Only the URL and then any text after that.


When Twitch’s AutoMod is turned on, EVEN if I have my URL set as an accepted phrase, the first part of the text will get removed before the URL.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.