Shoutout command removing @ not working

I can’t seem to get a shoutout command that removes the @ to work currently. I was using;

$(twitch $(eval $(touser).replace(/@/g,"")) "Go check out {{displayName}}, last streaming {{game}}. Show them some love at {{url}}")

Which worked fine until tonight. Now every time I use it I get the following response;

Unknown Twitch Channel

I’ve tried a few other command suggestions which remove the @ from the forums such as;

$(twitch $(eval "$(touser)".replace("@", "")) "Please give a big shoutout to {{displayName}}. Be sure to follow them at {{url}}")

$(twitch $(eval decodeURIComponent(`$(querystring)`).split(` `)[0].replace(/@/g,``)||`$(user)`) "Please give a big shoutout to {{displayName}} and be sure to follow them at {{url}} They were last seen streaming {{game}}.")

$(twitch $(eval `$(query)`.charAt(0) === '@' ? `$(query)`.slice(1) : `$(query)`) "{{displayName}} -- {{url}} -- {{views}} views -- {{followers}} followers")

But all come up with the same error.

I tried some of the examples on which seemed to have issues as well with;

$(twitch night "{{displayName}} has {{followers}} followers")

Which displayed the same error even when I changed “night” to another user. So I’m assuming something may be borked with the $(twitch) command? It only started happening recently and the ability to remove the @ when shouting out makes life a lot easier on mobile, so any ideas would be welcomed. I know I could use;


And that would work, but I don’t like having to go to/rely on another’s site and the amount you can customize the message is limited going this route.

I’m having this same issue. I was able to get it to work for my channel by using eval to change the input to lower case, but it doesn’t work anymore for getting data about other people’s channels. Seems to have broken some time today, as it was working for us about 24 hours ago. There’s definitely something funky going on with the $(twitch) command.

So currently it’s not the @ which is the problem.

Nightbot seems to be having issues with anything inside the $(twitch) command. Any inside variables are currently being somewhat ignored if they use a $() response.

For example:
$(twitch $(touser) “{{game}}”) wont work
$(twitch Lostdelirium “{{game}}”) will.

Currently I’m using a $(urlfetch) with a 3rd party API but it takes 3-5 seconds for the shoutout command to load which is annoying.

Hopefully they fix it soon.

It’s now fixed and working correctly :smiley:

This issue should now be resolved.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.