Node.js error with Streamtip 0.1.4


#1

Uncaught node.js Error

Error: spawn UNKNOWN
at exports._errnoException (util.js:742:11)
at ChildProcess.spawn (child_process.js:1122:11)
at exports.spawn (child_process.js:971:9)
at Object.exports.execFile (child_process.js:668:15)
at exports.exec (child_process.js:636:18)
at getDocumentsFolder (file:///C:/Users/RizTex/AppData/Local/Temp/nw5960_32212/resources/js/files.js:19:13)
at new Files (file:///C:/Users/RizTex/AppData/Local/Temp/nw5960_32212/resources/js/files.js:55:5)
at Object. (file:///C:/Users/RizTex/AppData/Local/Temp/nw5960_32212/resources/js/main.js:233:23)
at j (file:///C:/Users/RizTex/AppData/Local/Temp/nw5960_32212/resources/js/jquery.min.js:2:27244)
at Object.k.fireWith [as resolveWith] (file:///C:/Users/RizTex/AppData/Local/Temp/nw5960_32212/resources/js/jquery.min.js:2:28057)


#2

What version of Windows are you running?


#3

Windows 7 64 bit home premium


#4

You should have no problems running it. Go into a command prompt and type “cscript” and tell me the output.


#5

#6

What happens when you run it as a normal user without being in the system32 directory?


#7

#8

Can you download and install this version: https://streamtip.com/dl/StreamtipAlerter_0.1.4.exe


#9

This seems to be working now, but I’ve started to test donations. I have a ogg sound file Selected for recent and top but the donation sounds won’t play when I send a manual donation, (I am selecting send alert) it seems to be a 1/3 chance that the donation sound will play


#10

http://community.nightdev.com/t/debugging-the-streamtip-alerter-not-the-visual-alerter/1306


#11

I sent in the info :smiley: Hopefully this can get sorted, Thanks for working with me through it so far


#12

0.1.4 worked yesterday, but again same error as back with 0.1.3, Uncaught node.js

I dont have time to debug this currently I have to stream on a schedule, no donations for today. Ill look into it after stream.


#13

If you are getting the exact same stack trace as RizGames, try redownloading (I silently patched it for testing) and installing 0.1.4. If it doesn’t crash then but still doesn’t work properly, try running the program as an Administrator and see how it runs.

All of these crashes are related to how I am finding your Documents folder (because Windows is terrible and lets users move/rename the folder, I have a “hacky” solution that is being a bit annoying for some users).


#14

when i load up the program, i get the ungaucht node.js error with the following debug line. in the main window without opening the debug window:
Error: ENOENT, no such file or directory ‘C:\some\random\folder’
  at Error(native)
  at Object.fs.mkdirSync(fs.js:665:18)
  at file:///C:/users/theknerd/Temp/nw8_1564/resources/js/files.js:48:60
  at fs.js:289:14
  at Object.oncomplete(fs.js:97:15)


#15

It seems like you aren’t running the latest version…

Do the following:

  1. Uninstall the Streamtip Alerter from the “Uninstall a Program” section of the Windows Control Panel. If you see multiple Streamtip Alerter entries, uninstall all of them.
  2. Download and install the latest build of the alerter: https://streamtip.com/downloads

#16

i just downloaded the latest version today.


#17

Then follow the instructions I gave anyways… The error you’re getting shouldn’t be possible.


#18

This topic was automatically closed after 65 minutes. New replies are no longer allowed.