No sound in "preview stream"

Hi guys ! Quick question. So, after a format & clean install I’ve generated my follower alert as I had previously and added the &preview=true so I could see it pop up in my “preview stream” on OBS.

Text comes up but sound doesn’t play.
If I put the adress on chrome sound does play so it seems it’s hosted ok.

I’m using CLR Browser Plugin provided by Nightdev.

Any ideas ?

Can you try the url you are given with the &preview=true in a browser? Also, are you using 32 bit obs? I know you say you have the CLR Repack installed but maybe reinstall it to your 32 OBS plugin folder.

let me know how it goes.

In a regular browser (Chrome for Example) and using &preview=true I get text and sound both.

I’m using 32bit version of OBS v0.625b and Plugin is installed in the correct folder.

our repack found here right? - https://nightdev.com/clrbrowser3_repack.zip

also you file might be wrong format and size

has to be .ogg

I just reinstalled from that link and created a new Visual Alert, still have the same problem when I preview it in OBS I get the visual alert but no sound. File is .ogg and works like a charm when previewing it on chrome.

I honestly don’t test in OBS with the &preview=true most times if it works in the browser it will work in CLR. Have you tried setting it up and then streaming and waiting for someone to follow? If you have everything installed right and setup up it shouldn’t be an issue.

Did you maybe disabled the sound in OBS ? yeah i know that sounds like a fail only dumb ppl can make, but trust me, there are enough ppl who have a mutebutton on their keyboard and pressed it without knowing, wondeirng why they have no sound

Possible causes:

  • Sound file is not in ogg format.
  • Wrong CLR Browser version.
  • Wrong OBS version.
  • OBS is muted in sound settings.
  • Sound is longer then 10 seconds.
  • Sound file size is larger then 1MB.

Things to try:

  • Recreate the sound file. Use Audacity audio editor to re-export the file in ogg format.
  • Reinstall CLR Browser using the Nightdev repack (found here). Also try a manual install.
  • Use the 32bit version of OBS.
  • Check your sound settings, and insure OBS volume is not muted.
  • Use Audacity audio editor to create a shorter version of the sound file.
  • Reinstall OBS.

Not all of this applies to this circumstance, however it never hurts to try anyway…

OBS is not muted, I’m going to try and reinstall OBS from scratch now.

Did a clean install still the same problem. Here’s my log.

19:38:14: CLR host plugin strings not found, dynamically loading 4 strings
19:38:14: CLRHost::Initialize() attempting to load and start the .NET runtime (null)
19:38:14: CLRHost::Initialize() Found version v2.0.50727 .NET runtime
19:38:14: CLRHost::Initialize() Found version v4.0.30319 .NET runtime
19:38:14: CLRHost::Initialize() attempting to use v4.0.30319 .NET runtime
19:38:14: CLRHost::LoadInteropLibrary() load the assembly plugins\CLRHostPlugin\CLRHost.Interop.dll
19:38:14: CLRHost::LoadPlugins() attempting to load the plugin assembly CLRBrowserSourcePlugin
19:38:14: CLRHost:: Could not find/load browser settings at location C:\Users\Pancho\AppData\Roaming\OBS\pluginData\browser.json
19:38:14: CLRHost::LoadPlugins() successfully added CLR plugin [Type: CLRBrowserSourcePlugin.CLRBrowserSourcePlugin, Name: CLR Browser Source Plugin]

This topic was automatically closed after 72 minutes. New replies are no longer allowed.