Multiple issues with the Nightbot Beta AutoDJ

Nightbot: -> No song currently playing. Despite that the AutoDJ is what is playing music
Also, when it skips to the next song, the volume sometimes gets bumped to 100 for the first second or so of the song. No fun. :frowning:
Finally, is there any support for any sort program, etc. to pull the current song so it can be read by OBS in a text file?

Nightbot: -> No song currently playing. Despite that the AutoDJ is what is playing music

This is because you’re playing a song from your channel playlist, not from the song request queue. We recently changed the functionality of this page internally, which broke the current song functionality for playlists. We’re still working out a good solution to this problem and hope to have it fixed in the near future.

Also, when it skips to the next song, the volume sometimes gets bumped to 100 for the first second or so of the song. No fun. :frowning:

Unfortunately while we’ve tried our hardest to fix this issue it seems like some users still have this problem. We can no longer reproduce this problem, so we’re no longer able to try and fix the problem for users. If you have specific reproduction steps, it’s possible we may be able to reproduce it and fix it.

Finally, is there any support for any sort program, etc. to pull the current song so it can be read by OBS in a text file?

We are already working on a new application, but it isn’t ready yet. It contains more functionality than just pulling the current song, and we hope to have it released as an alpha sometime soon.

Is it not better to make the now playing thing also in a CRL brower thing?

Well I can give you a bit of the information regarding my usage so that maybe you stand a chance of reproducing!

1st: I use Google Chrome for my nightbot AutoDJ experience.
2nd: I generally am continuously streaming music, allowing it to skip on it’s own. It’s when I allow it to skip on it’s own accord that it tends to bump the volume.
3rd: I’m using Windows 10.

Hopefully this information can help in tracking down and correcting the issue!

Thanks for your patience. This issue is now resolved.

And were these songs YouTube videos or SoundCloud tracks? Can you provide examples of songs that bursted?

I can do that! Here’s a stream highlight, I’ll give you times to check with relevant YouTube or SoundCloud information!

Violators of my eardrums:
Pegboard Nerds - High Roller (feat. Splitbreed) [Guilty Pleasures EP] — Monstercat - (SoundCloud)
This song bursting: https://www.youtube.com/watch?v=j_93tT-Virg

Deon Custom - Roses — Monstercat - (SoundCloud)
This song bursting: https://www.youtube.com/watch?v=09poJMDg0Yg

There were several other occurrences, but they were all SoundCloud links. Something I did notice is if the window is active (selected and on the AutoDJ tab) it does not burst. However given I’m normally playing video games, this is a little bit difficult to manage. :stuck_out_tongue:

I hope I was able to help out and I’d love to help with any further testing of the Nightbot Beta. Unfortunately I can’t test with a large number of viewers. :confused: However I will see if my viewers will try to make the most of the uses of Nightbot!

Is there anyway of deleting playlists? I have a huge Monstercat playlist that I want to get rid of, but can’t seem to find how to do it.

If you mean the default playlist, you can swap to a “Channel” playlist in the settings at https://beta.nightbot.tv/song_requests

I was able to reproduce the issue when the tab wasn’t active. After debugging, it appears that the SoundCloud player API doesn’t function properly when the tab isn’t in active view. We’ve implemented a solution to the problem that isn’t ideal (there’s really no other viable way to fix it), but it works.

Yup, seems to be working fantastically! :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.