How to delete !permit command?

I have searched here and found two topics but no solution, only people asking why you want to delete it.
We have nightbot and moobot in this channel, moobot gives 3 mins with !permit and nightbot gives 60 seconds. When we use the !permit command both nighbot and moobot respond, so we would like to remove the nightbot command.

I tried using !command delete !permit in channel, that didn’t work.

Help? :smiley:


I dont think you can, however you can overwrite it and make it owner only:

OK, that’s great, thanks alot, I’ll do that.

Sorry to ressurrect this, although it’s within the 14 days! :slight_smile:

So this worked in that when people get timed out for bad links now, at least only moobot responds.
However, when using !permit command in chat, Moobot is overwritten by Nightbot, which I didn’t want, just because the timer is far less.

Here’s a screenshot of the current !permit command in Nightbot
Can you confirm I did it correct? And if so, how can I overwrite so that Moobot responds to !permit and not Nightbot?

Many thanks again!

Nope, you use -ul= to set the userlevel if you edit/add a command through the chat, in the backend you can just use the dropdown userlevel, change this to owner and set message to what ever you want.

OK! thanks very much.
So I changed it, using the dropdown box to Owner. Then it wanted me to put text in the message box before it would accept it, I just put n/a.

Tried it out and Moobot is back, but also Nightbot, so it’s not worked :frowning:

Any idea what I might have done wrong?

Thanks again!

Since it’s owner only Nightbot will only reply if you (the broadcaster) use it, but it wont reply to other mods who !permit your viewers.

1 Like

I’m not the owner though, just a mod:

And this is the command:

I must be doing something wrong?

Hmm, I thought that would work but just tested that and indeed it doesn’t overwrite it. Hopefully one of the Nightdev team can give you an other solution.

1 Like

I see, that’s a shame. Hopefully someone can help though.

Thanks very much xgerhard, you’ev been very helpful.

This should be fixed.

1 Like

Thanks night!

However, still not fixed :pensive:

I mean, I tested it after deploy and it does indeed work. Custom commands override it.

I can confirm it is working with an override:

OK, I don’t understand then, what am I doing wrong?

This is the permit command

And again, I just used permit, and I’m mod, not owner:

Any help would be appreciated, thanks guys!

If you disable link protection from Nightbot, it should also now disable the command.

If you mean this:

Then yes, it’s already done.

Anything else? and thanks!

If you’ve done that, then the issue is fixed as of my last post.

nice! :grinning:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.