Giveaways: Never finding eligible users

Hey folks,

Having an issue that only started with the new version of Nightbot. When I go to ‘Giveaways’ I can see users chatting on the right hand side, but no matter what kind of settings I set up I get a “there are no eligible users to win the giveaway” when I click “Roll it!”. I’ve never seen a user appear under ‘Users’ on the left hand side.

I’ve tried each kind of giveaway with no luck, and fiddled with the luck, timeout and eligibility settings to see if anything worked. No dice.

Nightbot had joined the chat and been modded.

Any help would be great - thanks!


Nightbot seems to detect users now - they are appearing under ‘Users’ on the left. Still having difficulty though:

  • Random Active user started working as intended.

  • Random Number still does not work - it will start the contest now, but does not declare a winner if the winning number is said in chat. Permanently says it’s waiting for someone to give the answer.

  • Keyword just seems to pick a random user from the chat. I enter a winning keyword, click ‘roll it’ and it immediately presents me with a winner without the keyword being said in chat.

It sounds like you’re unable to establish a stable connection to our server, which is unfortunate and cannot be fixed by us.

Without a stable connection the giveaway system will appear to break, when in reality it’s just that it’s breaking locally for you. The entire giveaway system runs solely in your browser from the incoming chat messages being streamed from Nightbot. Try using a different browser or internet connection. If you’re on wireless, try a wired connection.

Wow thanks for the response Night! the man himself…

Ah I was hoping to find a fix here. My connection is wired (only one network available) and I’m using Chrome - I guess I’ll try some other browsers and hope for the best. Stream’s going well just using the random active for now :smiley:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.