Disable Host Mode Not Working

There is nothing I hate more than falling asleep to a stream only for the calm, quiet streamer to host some loud, overhyped buddy of theirs who, nine times out of ten, seems to have a microphone dedicated to their extraordinarily loud mechanical keyboard, causing me to jolt out of sleep in the middle of the night calling for the vicar to close whatever hell portal has opened in my bedroom.

I have quintuple checked that the “Disable Host Mode” option for BTTV has been engaged. It is on. I’m looking at it right now. And yet I keep being dragged along into another channel when a streamer hosts someone.

What is happening and how do I fix it?


Hehe, nice description, yeah that can be annoying.
This feature breaks sometimes when Twitch changes their website.

Please create an issue here: https://github.com/night/BetterTTV/issues

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.