NightDev Community Forums

!8ball command not working

Hey! I’m a mod in my hubby’s twitch and can’t seem to figure out why this command wont work. I found it here under someone else’s topic and it worked like a charm for them?? I copied & pasted it exactly the way they had it displayed with no luck. Please help, it would be so awesome to use!

!addcom !8ball $(eval if(decodeURIComponent("$(querystring)")){r=$(urlfetch json https://8ball.delegator.com/magic/JSON/$(querystring));try{o=JSON.parse®;(o&&o.magic&&o.magic.answer||Failed to parse response: ${r}).substr(0,400)}catch(e){Failed to parse response: ${e.message}: ${r}.substr(0,400)}}else{“Ask a question!”})

I checked the original topic: Looking for 8ball command

The URL that the command is hitting (https://8ball.delegator.com/magic/JSON/) still seems to work, as does the command itself. Double check that you’ve copied the command code entirely. I’ve copied and pasted it below for your convenience.

!addcom !8ball $(eval if(decodeURIComponent("$(querystring)")){r=`$(urlfetch json https://8ball.delegator.com/magic/JSON/$(querystring))`;try{o=JSON.parse(r);(o&&o.magic&&o.magic.answer||`Failed to parse response: ${r}`).substr(0,400)}catch(e){`Failed to parse response: ${e.message}: ${r}`.substr(0,400)}}else{"Ask a question!"})

I must’ve done something wrong, it worked! Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.